summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-04 22:21:52 +0100
committerAndreas Stöckel <andreas@somweyr.de>2015-01-04 22:21:52 +0100
commit0d671f899da720ff5035bdab7adf6b11cbf80cb1 (patch)
tree9839d502ff323198d0f9cb479e9809a978c5c550 /CMakeLists.txt
parent7e1c72a5a5d5dc890a49f79c5daec3edcb38a33b (diff)
parent319ad738f677a20403cc27192f1df7bb65ce8c0e (diff)
Merge branch 'master' of somweyr.de:ousia
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a494c3..10e43ea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,6 +153,14 @@ TARGET_LINK_LIBRARIES(ousia_css
ousia_core
)
+ADD_LIBRARY(ousia_html
+ src/plugins/html/DemoOutput
+)
+
+TARGET_LINK_LIBRARIES(ousia_html
+ ousia_core
+)
+
ADD_LIBRARY(ousia_xml
src/plugins/xml/XmlParser
)
@@ -233,6 +241,16 @@ IF(TEST)
ousia_css
)
+ ADD_EXECUTABLE(ousia_test_html
+ test/plugins/html/DemoOutputTest
+ )
+
+ TARGET_LINK_LIBRARIES(ousia_test_html
+ ${GTEST_LIBRARIES}
+ ousia_core
+ ousia_html
+ )
+
ADD_EXECUTABLE(ousia_test_xml
test/plugins/xml/XmlParserTest
)
@@ -256,8 +274,9 @@ IF(TEST)
# Register the unit tests
ADD_TEST(ousia_test_core ousia_test_core)
ADD_TEST(ousia_test_boost ousia_test_boost)
- ADD_TEST(ousia_test_xml ousia_test_xml)
ADD_TEST(ousia_test_css ousia_test_css)
+ ADD_TEST(ousia_test_html ousia_test_html)
+ ADD_TEST(ousia_test_xml ousia_test_xml)
# ADD_TEST(ousia_test_mozjs ousia_test_mozjs)
ENDIF()