summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-10-16 00:39:35 +0000
committerandreas <andreas@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-10-16 00:39:35 +0000
commit0e426ff6dfb960c105908a437c435924e59eb822 (patch)
tree8e8080e478bf51c59bb1b7900c1abe96ffccf469 /CMakeLists.txt
parent5fcdd424d7bd798673b1b545f7f990aba65471a9 (diff)
reorganized code
git-svn-id: file:///var/local/svn/basicwriter@58 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt56
1 files changed, 10 insertions, 46 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a1a3e2..8c59356 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,9 +21,6 @@
PROJECT(basicwriter)
CMAKE_MINIMUM_REQUIRED(VERSION 2.8.9)
-SET(CMAKE_AUTOMOC ON)
-FIND_PACKAGE(Qt5Core REQUIRED)
-
# Option for enabling testing. Turn on with 'cmake -Dtest=ON'.
OPTION(test "Build all tests." OFF) # Makes boolean 'test' available.
@@ -54,50 +51,19 @@ INCLUDE_DIRECTORIES(
src/
)
-# ousia_model library (containing the code of the most important data structures
-# and deduction algorithms -- this code does not depend on Qt).
-ADD_LIBRARY(ousia_model
- src/model/GraphNode
- src/model/domain/Domain
- src/model/domain/Structure
- src/model/domain/ClassCategory
- src/model/domain/Class
- src/model/domain/ClassReferenceSet
- src/model/domain/ClassReference
- src/model/domain/Layer
- src/model/domain/AnnotationReference
- src/model/domain/Field
- src/model/domain/AnnotationCategory
- src/model/domain/Annotation
- src/model/types/Type
-)
-
-# ousia_xml library (containing the XML serialization/deserializing code for the
-# data structures defined in the ousia_model library)
-ADD_LIBRARY(ousia_xml
- src/xml/XmlReader
-)
-
-TARGET_LINK_LIBRARIES(ousia_xml
- ousia_model
+# ousia_script library (containing the code of t
+ADD_LIBRARY(ousia_script
+ src/core/script/Variant.cpp
)
-# Link the ousia xml model against the core module of Qt5
-QT5_USE_MODULES(ousia_xml Core Script)
-
# Definition of the main program
-ADD_EXECUTABLE(ousia
- src/main
-)
+#ADD_EXECUTABLE(ousia
+#)
# Link the ousia executable against ousia_core
-TARGET_LINK_LIBRARIES(ousia
- ousia_model
- ousia_xml
-)
-
-# Link the ousia executable against the Widgets module of Qt5
-QT5_USE_MODULES(ousia Widgets)
+#TARGET_LINK_LIBRARIES(ousia
+# ousia_script
+#)
# If testing is enabled, build the unit tests
IF(test)
@@ -109,14 +75,12 @@ IF(test)
# Add all unit test files
ADD_EXECUTABLE(ousia_test
- test/model/RangeSet
- test/model/GraphNode
+ test/core/model/RangeSet
)
TARGET_LINK_LIBRARIES(ousia_test
${GTEST_LIBRARIES}
- ousia_model
- ousia_xml
+ ousia_script
)
# Register the unit test