summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2014-03-06 11:54:40 +0000
committerbenjamin <benjamin@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-03-06 11:54:40 +0000
commit1cb5fdc15c5f8399ca08377eb498f7c27c2eee85 (patch)
tree1e3a23d78b094d40d9fb80ce8e330bdc113eb2e4 /CMakeLists.txt
parent247945811adbfb5ddaa1ba4e1f3dfc20cd7eb058 (diff)
reworked the model classes according to manipulated GraphNode and removed some bugs resulting from a misunderstanding between abtract domain declarations and instances.
git-svn-id: file:///var/local/svn/basicwriter@29 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26d695b..062d224 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,17 @@ INCLUDE_DIRECTORIES(
ADD_LIBRARY(ousia_model
src/model/GraphNode
src/model/domain/Domain
+ src/model/domain/Structure
+ src/model/domain/ClassCategory
+ src/model/domain/Class
+ src/model/domain/ClassReferenceSet
+ src/model/domain/ClassReference
+ src/model/domain/Layer
+ src/model/domain/AnnotationReference
+ src/model/domain/Field
+ src/model/domain/AnnotationCategory
+ src/model/domain/Annotation
+ src/model/types/Type
)
# ousia_xml library (containing the XML serialization/deserializing code for the