summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-10-18 00:56:14 +0000
committerandreas <andreas@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-10-18 00:56:14 +0000
commit25fb41044ca080b794cbf4e85ff10e74e571ea24 (patch)
tree59c5d648d32a2655778cefc26532c72efea963ea /CMakeLists.txt
parent14982ab94391bf9ec0b2ddba7f4517a0c834d0b1 (diff)
improved Variant.cpp, added ScriptEngine.hpp containing the script engine abstraction layer
git-svn-id: file:///var/local/svn/basicwriter@72 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fb3ac9..94bbcbd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,20 +51,27 @@ INCLUDE_DIRECTORIES(
src/
)
+# ousia_utils library
+ADD_LIBRARY(ousia_utils
+ src/core/utils/Utils.cpp
+)
+
# ousia_script library (containing the code of t
ADD_LIBRARY(ousia_script
src/core/script/Variant.cpp
+ src/core/script/ScriptEngine.cpp
+ src/core/script/
+)
+
+# Link the ousia executable against ousia_core
+TARGET_LINK_LIBRARIES(ousia_script
+ ousia_utils
)
# Definition of the main program
#ADD_EXECUTABLE(ousia
#)
-# Link the ousia executable against ousia_core
-#TARGET_LINK_LIBRARIES(ousia
-# ousia_script
-#)
-
# If testing is enabled, build the unit tests
IF(test)
# Include the gtest include files and the src directory
@@ -76,11 +83,13 @@ IF(test)
# Add all unit test files
ADD_EXECUTABLE(ousia_test
test/core/model/RangeSet
+ test/core/utils/Utils
test/core/script/Variant
)
TARGET_LINK_LIBRARIES(ousia_test
${GTEST_LIBRARIES}
+ ousia_utils
ousia_script
)