summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2014-03-04 17:16:59 +0000
committerbenjamin <benjamin@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-03-04 17:16:59 +0000
commit3ac3d683228cf0b0effe284bf07e18a9b07f92a2 (patch)
tree41f737a70e792f52ed93806c5bf62b030b15f277 /CMakeLists.txt
parentc736f9219673d049a1b21a0b9b2d01684a5b80dd (diff)
added anchor, annotation, field, layer and structure at least as raw concepts. Type and Value are dummy implementations.
git-svn-id: file:///var/local/svn/basicwriter@18 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 329b17d..e6a6ae4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,13 @@ INCLUDE_DIRECTORIES(src/)
ADD_LIBRARY(ousia_core
src/model/GraphNode
- src/model/domain/Domain
+ src/model/domain/Structure
+ src/model/domain/Layer
+ src/model/domain/Annotation
+ src/model/domain/Anchor
+ src/model/domain/Field
+ src/model/types/Type
+ src/model/types/Value
)
ADD_EXECUTABLE(ousia
@@ -48,6 +54,7 @@ if(test)
# Add all unit test files
ADD_EXECUTABLE(ousia_test
test/model/GraphNode
+ test/model/domain/Layer
)
TARGET_LINK_LIBRARIES(ousia_test