summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-11-03 00:33:30 +0000
committerandreas <andreas@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-11-03 00:33:30 +0000
commit3be38322647de269bf6f74c2a5a81501f168939c (patch)
tree229fe3bac6010ea7b5c086d38a4860ff81dd27dc /CMakeLists.txt
parentcba02d09ec724def40975240290a30a78d33db8a (diff)
implemented equals operator, fixed assignment operator, NodeManager now asserts that all nodes have been deleted in its destructor
git-svn-id: file:///var/local/svn/basicwriter@93 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index abf143b..0462460 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,14 +23,14 @@ CMAKE_MINIMUM_REQUIRED(VERSION 2.8.9)
# Option for enabling testing. Turn on with 'cmake -Dtest=ON'.
# TODO: Automatically activate tests if gtest is available
-OPTION(test "Build all tests." OFF) # Makes boolean 'test' available.
+OPTION(TEST "Build all tests." OFF) # Makes boolean 'test' available.
# Option for building the documentation.
FIND_PACKAGE(Doxygen)
OPTION(BUILD_DOCUMENTATION "Create and install the HTML based API documentation (requires Doxygen)" ${DOXYGEN_FOUND})
# Enable C++11 and all warnings
-SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O0 -Wall -pedantic-errors -std=c++11")
+SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pedantic-errors -std=c++11")
# Use PkgConfig to find mozjs-24
FIND_PACKAGE(PkgConfig REQUIRED)
@@ -65,7 +65,7 @@ ENDIF()
################################################################################
# Unit test handling
-IF(test)
+IF(TEST)
# Compile gtest
ADD_SUBDIRECTORY(lib/gtest-1.7.0)
@@ -118,7 +118,7 @@ TARGET_LINK_LIBRARIES(ousia_plugin_mozjs
)
# If testing is enabled, build the unit tests
-IF(test)
+IF(TEST)
#
# Core Test