summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-12-01 21:27:08 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-12-01 21:27:08 +0100
commit5554f3594d00e267af447a24149f655ceff64d17 (patch)
tree7a06022fcd5799a12a55e95d2e45414260cc45cf /CMakeLists.txt
parent082165d21269123f2658edc74aa1960669e306c8 (diff)
working version of the ParserStack class plus unit tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da6479b..327f664 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,8 @@ ADD_LIBRARY(ousia_core
# src/core/Typesystem
src/core/Utils
src/core/parser/Parser
+ src/core/parser/ParserStack
+ src/core/parser/Scope
src/core/script/Function
src/core/script/Object
src/core/script/ScriptEngine
@@ -156,6 +158,7 @@ IF(TEST)
test/core/RangeSetTest
test/core/TokenizerTest
test/core/UtilsTest
+ test/core/parser/ParserStackTest
test/core/script/FunctionTest
test/core/script/ObjectTest
test/core/script/VariantTest