summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-11 01:03:07 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-11 01:03:07 +0100
commit7950e05b381308a3beb3c6d1538de6af047e5c0c (patch)
tree70177ad76b5cdae74d551ed03e4acec939edd501 /CMakeLists.txt
parentc204e8dc7e0d4f1317747d5f7f2e17aab449de1a (diff)
Refactored conversion routines used in the Typesystem class and the Variant class into an own class, implemented missing conversion from string to integer/double, implemented proper JSON serialization of variants
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 781b9c4..88baf05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,7 +120,9 @@ ADD_LIBRARY(ousia_core
src/core/common/Terminal
src/core/common/Utils
src/core/common/Variant
+ src/core/common/VariantConverter
src/core/common/VariantReader
+ src/core/common/VariantWriter
src/core/managed/Events
src/core/managed/Managed
src/core/managed/Manager
@@ -202,6 +204,7 @@ IF(TEST)
test/core/common/LoggerTest
test/core/common/RttiTest
test/core/common/VariantReaderTest
+ test/core/common/VariantWriterTest
test/core/common/VariantTest
test/core/common/UtilsTest
test/core/managed/ManagedContainerTest