summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-20 17:46:41 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-20 17:46:41 +0100
commit8755bbe309d2f00c7bc73a6a6304ed8860a9a94d (patch)
treea364d21db838a5a27eb76a1639ddbdb882b4aedd /CMakeLists.txt
parentb61de477f91e9f6ec68a7e7b9ab5d4bddc632843 (diff)
Implemented automatic generation of default search paths
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b30e3f4..2d19b18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,6 +81,18 @@ IF(TEST)
ENDIF()
################################################################################
+# Commands for assembling and including the configuration file #
+################################################################################
+
+CONFIGURE_FILE(
+ "${PROJECT_SOURCE_DIR}/config.h.in"
+ "${PROJECT_BINARY_DIR}/config.h"
+)
+
+# Adapt the include path for finding the configuration file
+INCLUDE_DIRECTORIES("${PROJECT_BINARY_DIR}")
+
+################################################################################
# Commands for building Ousía #
################################################################################