summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2014-11-13 18:08:18 +0100
committerBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2014-11-13 18:08:18 +0100
commitbc4d1cb7dcbbab9bca7f75e2e0c70d54493aae0b (patch)
tree42f9f023de91129cf82cb77752fe3970e7cf9a25 /CMakeLists.txt
parent4771958cf7042d5799eb7591c1abb3d986f8a42a (diff)
started to implement the CSSParser. First iteration only contains the CSS Specificity.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58fa742..53fa6a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,6 +95,7 @@ ADD_DEFINITIONS(
)
# ousia_script library (containing the bindings needed for script engines)
+# TODO: This is not only the script library.
ADD_LIBRARY(ousia_core
src/core/dom/Managed
src/core/dom/Node
@@ -103,6 +104,7 @@ ADD_LIBRARY(ousia_core
src/core/script/ScriptEngine
src/core/script/Variant
src/core/utils/BufferedCharReader
+ src/core/utils/CSSParser
src/core/utils/Tokenizer
src/core/utils/Utils
)
@@ -138,6 +140,7 @@ IF(TEST)
test/core/script/ObjectTest
test/core/script/VariantTest
test/core/utils/BufferedCharReaderTest
+ test/core/utils/CSSParserTest
test/core/utils/RangeSetTest
test/core/utils/TokenizerTest
test/core/utils/UtilsTest