summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-03-04 12:59:32 +0000
committerandreas <andreas@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-03-04 12:59:32 +0000
commitc543117ff43c63a053ea786ed606398ac4687494 (patch)
treebf13926dff41782831fbf5fc37c274f09f7a0360 /CMakeLists.txt
added source code
git-svn-id: file:///var/local/svn/basicwriter@12 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..da91330
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+PROJECT(basicwriter)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.9)
+
+SET(CMAKE_AUTOMOC ON)
+FIND_PACKAGE(Qt5Widgets REQUIRED)
+
+INCLUDE_DIRECTORIES(src/)
+
+# Enable C++11 and all warnings
+SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pedantic -std=c++11")
+
+ADD_EXECUTABLE(basicwriter
+ src/main.cpp
+ src/gui/notepad.cpp
+ src/gui/components/UIPaneFrame.cpp
+# src/gui/components/UIGrid.cpp
+# src/gui/components/GridTree.cpp
+)
+
+QT5_USE_MODULES(basicwriter Widgets)