summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-02-02 01:59:57 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-02-02 01:59:57 +0100
commitcbeffc5776c93a1b6380d9edfda231c8482f71f5 (patch)
tree1101bde560ac9e960d2e158e48fd70601ee7b2e2 /CMakeLists.txt
parente4071ff5894d13e95f72457aac68899610e5d7eb (diff)
Introduced RootNode class from which Document, Domain and Typesystem should derive. This class is needed for the "import" handler.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc62b75..04af853 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,6 +146,7 @@ ADD_LIBRARY(ousia_core
src/core/model/Index
src/core/model/Node
src/core/model/Project
+ src/core/model/RootNode
src/core/model/Style
src/core/model/Typesystem
src/core/parser/Parser