summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-20 01:52:19 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-20 01:52:19 +0100
commitd98161ba6b7453932958e05ffa10a2e1a6a52d0a (patch)
treed904bfe462b27a339eb5457e63a28bb9cae365bc /CMakeLists.txt
parentda5a43bc2f2f1697dbfbf6a22f1b35a1af8848ce (diff)
Installing files in the data directory to the correct location with correct permissions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 432dbcb..623ae7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,8 +62,6 @@ IF(BUILD_DOCUMENTATION)
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
COMMENT "Generating API documentation with Doxygen"
VERBATIM)
-
- INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc)
ENDIF()
@@ -290,3 +288,17 @@ IF(TEST)
# ADD_TEST(ousia_test_mozjs ousia_test_mozjs)
ENDIF()
+################################################################################
+# Commands for building installing #
+################################################################################
+
+INSTALL(DIRECTORY data/ DESTINATION share/ousia
+ FILE_PERMISSIONS
+ OWNER_READ GROUP_READ WORLD_READ
+ OWNER_WRITE
+ DIRECTORY_PERMISSIONS
+ OWNER_READ GROUP_READ WORLD_READ
+ OWNER_WRITE
+ OWNER_EXECUTE GROUP_EXECUTE WORLD_EXECUTE
+)
+