summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2014-03-06 00:11:17 +0000
committerandreas <andreas@daaaf23c-2e50-4459-9457-1e69db5a47bf>2014-03-06 00:11:17 +0000
commitd99095f4a181357bf0c6d10846351eb0b58b1ccf (patch)
tree74daacc842023b14e27aa49403ee8d4aaa8bb172 /CMakeLists.txt
parentf098dc45183d2b7a99e65b62448f59d12cc3c056 (diff)
started to implement rudimentary XML reader (implemented expectOneOf function), changed some conventions in the used files (namespaces, include guards), moved anchor class from domain to document package, removed everything that does not work now from the CMakeLists.txt
git-svn-id: file:///var/local/svn/basicwriter@24 daaaf23c-2e50-4459-9457-1e69db5a47bf
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 21 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c9956a..26d695b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,19 +54,26 @@ INCLUDE_DIRECTORIES(
src/
)
-# ousia_core library (containing the code of the most important data structures
-# and deduction algorithms)
-ADD_LIBRARY(ousia_core
+# ousia_model library (containing the code of the most important data structures
+# and deduction algorithms -- this code does not depend on Qt).
+ADD_LIBRARY(ousia_model
src/model/GraphNode
- src/model/domain/Structure
- src/model/domain/Layer
- src/model/domain/Annotation
- src/model/domain/Anchor
- src/model/domain/Field
- src/model/types/Type
- src/model/types/Value
+ src/model/domain/Domain
)
+# ousia_xml library (containing the XML serialization/deserializing code for the
+# data structures defined in the ousia_model library)
+ADD_LIBRARY(ousia_xml
+ src/xml/XmlReader
+)
+
+TARGET_LINK_LIBRARIES(ousia_xml
+ ousia_model
+)
+
+# Link the ousia xml model against the core module of Qt5
+QT5_USE_MODULES(ousia_xml Core)
+
# Definition of the main program
ADD_EXECUTABLE(ousia
src/main
@@ -74,7 +81,8 @@ ADD_EXECUTABLE(ousia
# Link the ousia executable against ousia_core
TARGET_LINK_LIBRARIES(ousia
- ousia_core
+ ousia_model
+ ousia_xml
)
# Link the ousia executable against the Widgets module of Qt5
@@ -92,12 +100,12 @@ IF(test)
ADD_EXECUTABLE(ousia_test
test/model/RangeSet
test/model/GraphNode
- test/model/domain/Layer
)
TARGET_LINK_LIBRARIES(ousia_test
${GTEST_LIBRARIES}
- ousia_core
+ ousia_model
+ ousia_xml
)
# Register the unit test