summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-27 01:40:54 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-27 01:40:54 +0100
commitec7f4ee73430906bf53648eba427bfad353a7409 (patch)
treeacd16dba92fa9702fa45c456a321b664de96c0c3 /CMakeLists.txt
parent84f0004cdf45f6fbad6461676897aa27f03cbb93 (diff)
parenta95cf9c477f7259f04d3759acec40a4070ae2b31 (diff)
Merge branch 'master' of somweyr.de:ousia
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 25 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c0daa8a..9e4979e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,7 +38,7 @@ PKG_CHECK_MODULES(MOZJS REQUIRED mozjs-24)
PKG_CHECK_MODULES(EXPAT REQUIRED expat)
# Include required Boost components using the Boost cmake package
-FIND_PACKAGE(Boost COMPONENTS system filesystem REQUIRED)
+FIND_PACKAGE(Boost COMPONENTS system filesystem program_options REQUIRED)
# Set utf8cpp include path
SET(UTF8CPP_INCLUDE_DIR "lib/utf8cpp")
@@ -116,7 +116,6 @@ ADD_DEFINITIONS(
ADD_LIBRARY(ousia_core
src/core/CodeTokenizer
- src/core/CSS
src/core/Registry
src/core/Tokenizer
src/core/XML
@@ -146,6 +145,7 @@ ADD_LIBRARY(ousia_core
src/core/model/Index
src/core/model/Node
src/core/model/Project
+ src/core/model/Style
src/core/model/Typesystem
src/core/parser/Parser
src/core/parser/ParserContext
@@ -158,22 +158,22 @@ ADD_LIBRARY(ousia_core
# src/core/script/ScriptEngine
)
-ADD_LIBRARY(ousia_filesystem
- src/plugins/filesystem/FileLocator
- src/plugins/filesystem/SpecialPaths
+ADD_LIBRARY(ousia_css
+ src/plugins/css/CSSParser
)
-TARGET_LINK_LIBRARIES(ousia_filesystem
+TARGET_LINK_LIBRARIES(ousia_css
ousia_core
- ${Boost_LIBRARIES}
)
-ADD_LIBRARY(ousia_css
- src/plugins/css/CSSParser
+ADD_LIBRARY(ousia_filesystem
+ src/plugins/filesystem/FileLocator
+ src/plugins/filesystem/SpecialPaths
)
-TARGET_LINK_LIBRARIES(ousia_css
+TARGET_LINK_LIBRARIES(ousia_filesystem
ousia_core
+ ${Boost_LIBRARIES}
)
ADD_LIBRARY(ousia_html
@@ -202,6 +202,20 @@ TARGET_LINK_LIBRARIES(ousia_xml
# ${MOZJS_LIBRARIES}
#)
+# Command line interface
+
+ADD_EXECUTABLE(ousia
+ src/cli/Main
+)
+
+TARGET_LINK_LIBRARIES(ousia
+ ousia_core
+ ousia_css
+ ousia_filesystem
+ ousia_html
+ ousia_xml
+)
+
# If testing is enabled, build the unit tests
IF(TEST)
@@ -212,7 +226,6 @@ IF(TEST)
ADD_EXECUTABLE(ousia_test_core
test/core/CodeTokenizerTest
- test/core/CSSTest
test/core/RangeSetTest
test/core/RegistryTest
test/core/TokenizerTest
@@ -238,6 +251,7 @@ IF(TEST)
test/core/model/DocumentTest
test/core/model/IndexTest
test/core/model/NodeTest
+ test/core/model/StyleTest
test/core/model/TypesystemTest
test/core/parser/ParserStackTest
test/core/resource/ResourceLocatorTest