summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26d695b..062d224 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,17 @@ INCLUDE_DIRECTORIES(
ADD_LIBRARY(ousia_model
src/model/GraphNode
src/model/domain/Domain
+ src/model/domain/Structure
+ src/model/domain/ClassCategory
+ src/model/domain/Class
+ src/model/domain/ClassReferenceSet
+ src/model/domain/ClassReference
+ src/model/domain/Layer
+ src/model/domain/AnnotationReference
+ src/model/domain/Field
+ src/model/domain/AnnotationCategory
+ src/model/domain/Annotation
+ src/model/types/Type
)
# ousia_xml library (containing the XML serialization/deserializing code for the