summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 20 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec1bb4d..eb4016f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,6 +233,14 @@ TARGET_LINK_LIBRARIES(ousia_html
ousia_core
)
+ADD_LIBRARY(ousia_xml
+ src/plugins/xml/XmlOutput
+)
+
+TARGET_LINK_LIBRARIES(ousia_xml
+ ousia_core
+)
+
#ADD_LIBRARY(ousia_mozjs
# src/plugins/mozjs/MozJsScriptEngine
#)
@@ -244,17 +252,19 @@ TARGET_LINK_LIBRARIES(ousia_html
# Command line interface
-#ADD_EXECUTABLE(ousia
-# src/cli/Main
-#)
+ADD_EXECUTABLE(ousia
+ src/cli/Main
+)
-#TARGET_LINK_LIBRARIES(ousia
-# ousia_core
-# ousia_filesystem
-# ousia_html
-# ousia_xml
-# ${Boost_LIBRARIES}
-#)
+TARGET_LINK_LIBRARIES(ousia
+ ousia_core
+ ousia_filesystem
+ ousia_html
+ ousia_xml
+ ousia_osml
+ ousia_osxml
+ ${Boost_LIBRARIES}
+)
# If testing is enabled, build the unit tests
IF(TEST)