summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-21 01:17:49 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-01-21 01:17:49 +0100
commit6decad0b8e7e369bd8215f31a45dd3eae982d2a9 (patch)
tree96d22db47629956c554d11a9e56bc68a2fc9b40b /CMakeLists.txt
parent311a770805dff2cdffc1ecbfbbf0c5aae44c8878 (diff)
Some further refactoring -- renamed Scope to ParserScope, got rid of parser namespace, added new functionality to RegistryClass, wrote documentation, added function for extracting file extensions to Utils
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d19b18..2b8efc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,8 +145,9 @@ ADD_LIBRARY(ousia_core
src/core/model/Project
src/core/model/Typesystem
src/core/parser/Parser
+ src/core/parser/ParserContext
+ src/core/parser/ParserScope
src/core/parser/ParserStack
- src/core/parser/Scope
src/core/resource/Resource
src/core/resource/ResourceLocator
# src/core/script/ScriptEngine