summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-02-22 23:06:54 +0100
committerAndreas Stöckel <astoecke@techfak.uni-bielefeld.de>2015-02-22 23:06:54 +0100
commitcb697e7eb78ad0bdfc2a20a7bdd2c369b678ca09 (patch)
treeb75bb61ce1467fca50133c2dd5c6bcdc551dc0e8 /CMakeLists.txt
parent6ace07685cbaa81338ec5e68487054dcbf9da969 (diff)
Implemented TokenizedData, a facility to store data with tokens where tokens can be dynamically enabled and the whitespace mode specified at the moment the tokens are read
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9a47d2..ea5c3aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -190,6 +190,7 @@ ADD_LIBRARY(ousia_core
src/core/parser/stack/TypesystemHandler
src/core/parser/utils/SourceOffsetVector
src/core/parser/utils/Token
+ src/core/parser/utils/TokenizedData
src/core/parser/utils/Tokenizer
src/core/parser/utils/TokenTrie
src/core/resource/Resource
@@ -325,6 +326,7 @@ IF(TEST)
test/core/parser/stack/StackTest
test/core/parser/stack/StateTest
test/core/parser/utils/SourceOffsetVectorTest
+ test/core/parser/utils/TokenizedDataTest
test/core/parser/utils/TokenizerTest
test/core/parser/utils/TokenTrieTest
test/core/resource/ResourceLocatorTest