summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2015-01-06 22:38:49 +0100
committerBenjamin Paassen <bpaassen@techfak.uni-bielefeld.de>2015-01-06 22:38:49 +0100
commitfd8ce97afb16e17102ec8f109103ed334ad0e939 (patch)
treebe609366b106940252c36bdfb3f02e677e9c3e3a /CMakeLists.txt
parent0778a9446dc3475b887d20515165a4dc63ed0cd0 (diff)
added XML classes including Serialization functions and added a test for it. I tried not to include Managed.hpp to prevent further overhead but I failed miserably.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10e43ea..e67e2be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,7 @@ ADD_LIBRARY(ousia_core
src/core/Registry
src/core/ResourceLocator
src/core/Tokenizer
+ src/core/XML
src/core/common/CharReader
src/core/common/Exceptions
src/core/common/Function
@@ -194,6 +195,7 @@ IF(TEST)
test/core/RegistryTest
test/core/ResourceLocatorTest
test/core/TokenizerTest
+ test/core/XMLTest
test/core/common/CharReaderTest
test/core/common/FunctionTest
test/core/common/LoggerTest